walk down that lonesome road of dae errors

Sometimes, despite you’re best intentions, things just go wrong. I know, because that’s exactly what happened to me today. I sat down at a workstation that worked perfectly the day before (ok, not perfectly, but you get the point), opened up ProTools with my MBox 2 Pro attached, and that’s when the trouble began.

To rewind a bit, there’s a light on the front panel of the MB2Pro. Mine is green because I use the power supply, however it can also be amber if it’s drawing bus power.

image via Digidesign

Yep, that’s the pesky little power light, right above the External Clock and MIDI lights. However, for some reason, mine was blinking consistently on and off. I knew that if no lights were lighted then the firmware was compromised. However, I could find nothing that explained away a blinking power light. So, I decided to launch into ProTools and see if it would just go away.

Nope… I was greeted at the splash screen with an error. Not just any error, mind you, but one I had never before encountered; DAE Error 700. Being no stranger to DAE Errors, I figured my best bet (and yours, if you’re ever in a similar situation), was to first head to the Digi User Conference (DUC) and do a little searching. Unfortunately, a search yielded 2 pages of fairly useless and unrelated information. However, there was one helpful post that reminded me to delete all my preferences and reboot. Nothing I didn’t already know, but a welcome suggestion at this point. Moving on, a search on the Digidesign Support Knowledge Base yielded 55 pages of possibilities, none of which had anything remotely to do with DAE Error 700, so onward I marched.

Deciding to use what advice I could from the DUC, I fired up the extremely helpful ProTools Prefs & Database Helper by Jean-Charles Deshaies which greatly expedites the process of deleting the multitude to ProTools and Digidesign databases across a system.

While using Mr. Deshaies’ excellent utility certainly saved me some time, I was still receiving DAE Error 700 even after running the utility, emptying the Trash, and rebooting ProTools. So, I was at an impasse. After some serious Google searching I had discovered only one post even slightly related other than what I’d found on the DUC, which pertained to the engineer receiving the same error immediately after experiencing a terrible feedback loop.

So, I got to thinking… and I remembered that my MBox 2 Pro also has a Preference Pane in System Preferences. I didn’t recall it controlling much, but as I couldn’t get ProTools to launch, what did I have to lose?

Yep, there it was, lurking under “Other.” Upon inspection, I found that I had only two, maybe three options. I could learn about my Firmware version, change my Clock Source, or I could Mirror Analog 1-2 or S/PDIF.

Assuming that my DAE Error didn’t have anything to do with a long standing feud between Analog 1-2 and S/PDIF, I decided no worse a fate would befall me if I changed my clock source from Internal to Word Clock. It’s worth noting at this point, that the only connections between my MB2Pro and my mixer are 2 TRS cables.

Lo and behold, suddenly my power light locked solid and the External Clock light began to blink, as it couldn’t find an external sync. Hoping for a second stroke of luck, I changed the Clock Source back to internal and the power light remained solid. Emboldened, I launched into ProTools without incident and continued along my day without incident. What was the real cause of the problem. I may never know…

Is there a lesson in all this? Absolutely! Knowing where to go when any program, especially ProTools, gives you errors is crucial. My first stop is always the DUC because it provides real world solutions and advice from Digidesign users, followed by the Digidesign Support page which allows you to search by error number and error phraseology. If I still haven’t found an answer, that’s when I hit Google. Hopefully, if your issue isn’t documented in the DUC or the Digidesign KB, then someone has documented their experience in a blog post. Who knows, maybe that’s the precise reason you’re here? Either way, I hope you’ve found this information useful, and happy error quashing!

Have a thought on DAE or other errors? Have a tried and true method of troubleshooting these masters of darkness other than Knowledge Base spelunking? Please let me know in the comments!

thumbnail via Wikimedia Commons

Kyle P. Snyder

Kyle P. Snyder is an educator, engineer, and consultant dedicated to the advancement of audio education for engineers at every stage of development. He is a faculty member within Ohio University’s School of Media Arts & Studies where he routinely teaches courses in music production, recording, mixing and mastering, critical listening, sound design for film and video, and live event production.

  • ybabe

    How bizarre! This morning I had the same DAE error 700, googled it and arrived at this website. I did what you did, changed the clock source to word clock, then back to internal, and all was well. Thank you for posting! What would we do without the internet??